
 Atavism Game Launcher for Windows Setup Guide Doc Version: 
22.8.27.4 

 
 

 

Note: The online documentation at https://blog.visuafusion.com/AtavismGameLauncherforWindows may be more up to date 
than the document files included in the package.  
 
Note: As of version 22.8.27.4, the launcher utilizes .glconfig files instead of .config files.  Screenshots in the documentation will 
be updated at a later date.  
 

1. Set Up your Webserver to host the Launcher Solution 
a. Prepare web server file hosting directories 

You will need to configure a game files directory with both “GameClient” and “Launcher” 
subdirectories on your web server.  The Launcher Directory will need a “Game File Hash 
Lists” subdirectory within it as well.  I’d recommend setting this all up under a “<Game 
Name> -> <Release Branch>” structure, as shown here: 

 
Note: Other than your game’s name and release branch name, the last 3 directory names must match 
exactly, and the structure must be set up as shown above 

b. Note down your Web Server’s paths Newly create paths from step (a) 
i. Launcher Download Root URL (Launcher Directory from step A) – Example: 

https://ArcanicaEntertainment.com/Downloads/GameFiles/Atavism Demo/Dev/Launcher 
ii. Client Download Root URL (Launcher Directory from step A) – Example: 

https://ArcanicaEntertainment.com/Downloads/GameFiles/Atavism Demo/Dev/GameClient 
 

2. Configuring the Launcher Configuration Files and Supporting Texts 
a. BaseConfig.glconfig – This file is the first initial config file that tells the launcher where to 

go and what to be called.  Open Launcher Build Kit -> Launcher-Install Build -> Payload -> 
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Config -> BaseConfig.glconfig with notepad, and configure the following values: 

 
i. BaseConfigPackageVersion: version in x.x.x.x format (YY.MM.DD.<revision> format 

works great here) 
ii. GameName: The name of your game (Spaces are allowed in the value) 

iii. PublisherName: Your company name (Spaces are allowed in the value) 
iv. LauncherDownloadRootURL: The Launcher Download Root URL you wrote down in 

Section 1, step b. 

 
b. MainConfig.glconfig – This file is the main configuration file that houses most of the 

values the launcher will use (color scheme, publisher contact info, Button URLs, Game 
EXE name, etc.  Most importantly, this file downloads from your web server each time 
the launcher starts up, and the package version value in this config file is compared to 
the package version value in the local BaseConfig.glconfig file – if the 
BaseConfig.glconfig’s package version value is less than the newly downloaded 
MainConfig.glconfig’s version value, a launcher update is triggered (this process is 
covered later in this document).  Open Launch Build Kit -> Pace on Server -> 
MainConfig.glconfig in Notepad, and configure the following values: 

 
i. CurrentConfigPackageVersion: version in x.x.x.x format (This will typically match the 

version you set up in BaseConfig.glconfig if this is your first initial time setting up the 
launcher solution) 

ii. ClientDownloadRootURL: The Client Download Root URL you wrote down in Section 
1, step b. 
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iii. GameEXEName: The name of your games executable file once built, this can be 

found/set in Unity by going to Edit -> Project Settings and looking at the Product Name 
– whatever value is here is what the built EXE will be named (in the example shown, 
the EXE name will be “X5 Demo.exe” 

 
iv. PublisherContactEmail: The email you would like people to contact you at for support 

(IE: support@atavismonline.com) 
v. GameWebsite: The main website for your game or company (this is used in 

add/remove programs listing only) 
vi. MenuButton(1-4)URL: Set up URLs you’d like users to have buttons for here.  Buttons 

are ordered from left to right (1 is the farthest left button on the top of the launcher)  

 
c. GameReleaseNotes.txt – edit this document in notepad, include your release notes for 

your game.  This will be something you update as you upload new versions of your game 
(This will be covered more farther along in this document). 

d. Player-EULA.txt – edit this document in notepad, include your end user license 
agreement.  This will be displayed to users both during launcher install as well as when 
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choosing a game client location before initially downloading/installing the game from the 
launcher itself. 

3. Upload Initial Server-Side Files 
a. Upload the files in the “Launcher Build Kit\Place on Server” directory to your web 

server’s “Launcher” directory (The Launcher Download Root URL you wrote down in 
Section 1, step b.) 

 
 

4. Adding Launcher integration to your Atavism Game 
a. Import the Unity Package 

With your Atavism Project loaded in Unity, Import the AtavismGameLauncherForWindows-
XX.XX.XX.XX.unitypackage Package into your unity project by clicking on Assets -> Import Package 
-> Custom Package.
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b. Select Items for Import 

Import all the items in the package into your project by making sure everything is checked and 
clicking “import”. 
 

 
c. Configure the “Launcher_Validation” scene to use your web server 

The script attached to the Launcher_Validation scene’s canvas object needs the Launcher 
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Validation List URL we set up earlier.  Include either http:// or https:// as well as 
“FileHashesList.launchervallst” in the path, this is used to directly download the list.

 
d. Ensure the UI objects are assigned in Launcher check script 

Make sure the Notification Message Window and Notification Message Text objects are assigned 
in the Launched From Launcher Check script attached the Canvas object 

 
Feel free to customize the UI of this scene to match your game, just make sure everything above is 
assigned as shown when you are finished.  You may also optionally uncheck the “Validation 
Required to Play” checkbox, which will allow players to continue to the login scene upon failing 
validation (Usually, this is not wanted – you don’t need to do this to enable play from the editor, 
the validation script already skips checking if it detects it is running from the editor) 

e. Include the “Launcher_Validation” scene in your build 
The package includes a “Launcher_Validation” scene which needs to be included and set as the 
1st scene in your build order.  To do this Open the Launcher_Validation scene in Project -> Assets -
> OtherPackages -> Atavism Extras -> Atavism Game Launcher for Windows -> 
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Launcher_Validation and double click the scene to open it. 

 
With the Launcher_Validation Scene Open, go to File -> Build Settings and click on “Add Open 
Scenes” under the Scenes in Build list.   

 
f. Set the “Launcher_Validation Scene as the first scene in your build order 

The newly added scene will be at the bottom of the list at first, you will need to drag it to the top 
until it is in position 0.  Don’t forget to Save your project at this point.  It is important that the 
launcher validation scene is first so that it can verify players have launched the game with the 
launcher, and that the game is up to date before moving to the login scene! 
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5. Customize your Launcher to match your game 
This step is optional, and you can come back to it later if you just want to get up and running.   
If you do come back to this later (or want to update your launcher theme/package), you will 
need to: 
 1. update the “BaseConfigPackageVersion” setting in “BaseConfig.glconfig” with a higher 
package version number (this gets compressed and installed with the new build version in 
the Launcher-Installer Package create in section 6) 
 2. Update the “CurrentConfigPackageVersion” setting in “MainConfig.glconfig” to the same 
new version number you placed in “BaseConfig.glconfig” (which you will then need to 
reupload to your web server’s “Launcher” directory (The Launcher Download Root URL you 
wrote down in Section 1, step b.) 
 3. Perform this section as well as the “Create a Launcher-Install Package”, “” section again 
 - Doing these things will trigger older launcher builds to see a newer launcher build version on your 
web server and download it and update, at which point the versions will match and the installed 
launcher will be the “current” one, along with any customizations you made following this section. 
4.  If Keeping your existing configuration files through updating to a new launcher version, 
make sure to check for new configuration values by checking the provided example config 
files included with the new launcher version!  
 
------------------------------------------- Customization Process --------------------------------------------- 

a. Background, Buttons, Frames: The launcher loads all it’s images used from the Launcher-
Install Build\Payload\Resources directory.  You can change/modify these as you like, but 
you must maintain the resolution/sizing in order for everything to fit correctly.  The 
names must remain the same for the launcher to utilize them.  There are many graphic 
editing softwares out there, I personally use Adobe Photoshop Elements (About $99 
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USD), Krita (Free and awesome), and GIMP (Free and awesome) depending on what I’m 
doing. 

 
b. Icon: The launcher, as well as the installer and update screens will utilize the 

Launcher.ico file from the Launcher-Install Build\Payload\Resources directory.  You can 
replace it with your own, however, the icon must be named “Launcher.ico” for the 
launcher to utilize it.  It is recommended to create an ico file that includes at minimum 
the following resolutions: 256x256, 128x128, 96x96, 64x64, 48x48, 32x32, 24x24, and 
16x16 resolutions included (all 32-bit is fine).  There are many softwares out there to 
create ico files, I personally use IcoFX (about $40 USD). 

c. Text and Progress Bar color: Text and Progress bar color can be set in the 
MainConfig.glconfig file you uploaded to your server’s Launcher Download Root URL you 
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wrote down in Section 1, step b.  The values need to be in hex format (you can use 
https://www.colorhexa.com/ to find those easily), you should leave the # symbol off.  
Note that if all you are wanting to change is text color and/or progress bar color, you can 
do this step by itself, there is no need to make a new launcher build as the launcher 
downloads the MainConfig.glconfig file each time it starts up, so all you have to do is 
update this file and overwrite the old one on your server.  In version 22.3.27.8, a 
separate color parameter was added for Release Note text color – if it is not set or 
missing in the MainConfig.glconfig file the launcher downloads from your server, it will 
default to the TextColor’s value. 
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6. Create a Launcher-Install Package 
Users will use this to install your launcher, which will then manage downloading your game and 
keeping it up to date forever after.  You will need 7zip installed on your dev computer for this part, 
as we will be creating a compressed self-extracting installer for your end users. 

a. Locate The Launcher-Install Build Directory 
In the Launcher Build Kit directory, open the Launcher-Install Build directory 

 
b. Create a 7z archive with the Payload and the Launcher-Installer.exe 

Select the “Payload” directory, as well as the “Launcher-Installer.exe” file (Ctrl+click Them) and 
right-click on them, select “Add to Launcher-Install Build.7z”.  Wait for 7z to finish creating your 
.7z file. 

 
c. Launch an elevated command prompt and navigate to the Launcher-Install Build directory 

Click on your start menu button type “cmd” 

 
Right-Click on “Command Prompt” and select “Run as administrator” 

 
Type “CD <Path to Launcher-Install Build directory>” and press enter 
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Note: If the drive of the Launcher-Install Build folder is different that the path showing initially, 
you will first need to type the new drive name and hit enter to move to that drive: Example – D: 
(Enter key) 

d. Make a self extracting installer from the .7z archive 
In the Launcher-Install Build directory, open up “7z Build String.txt” and copy it’s contents to your 
clipboard by highlighting the text, right clicking, and selecting “copy” 

 
Note: If you accidentally delete the contents of this at some point, it is: copy /b 7zSD.sfx + config.txt + 
"Launcher-Install Build.7z" "Launcher-Install.exe" 
Paste the copied text into the elevated command prompt and press the enter key.  Wait for 
“Launcher-Install.exe” to finish building – it should be slightly larger in size than Launcher-Install 
Build.7z.  If it is not, delete it and go back through part 5 from the beginning.  Do NOT change the 
names of any of the files, everything must be named this way for things to work. 

 
e. Copy “Launcher-Install.exe” to the server 

Copy the Launcher-Install.exe you just created to the Launcher Download Root URL you 
wrote down in Section 1, step b. 
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7. Create a Build of your Game in Unity 
a. In Unity, go to File -> Build Settings, and click Build.  Note that if you use any of the Non-

Standard compression methods, the launcher will still work, but clients will redownload 
the entire game vs. individual files that have changed.  Selecting “Default” here gives the 
best patching experience for your players. 

  
b. Create a directory somewhere for your build (remember where), and click “Select 

Folder”. 

   
c. Wait for Unity to finish the build 
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d. When the build finished, copy the contents of the build folder up to your web server’s 

Client Download Root URL you wrote down in Section 1, step b.  Let the upload finish 
before moving on to the final step of the process. 

  
8. Create a File Hash Validation List and copy it up to your web server 

The launcher uses a File Hash Validation list downloaded each time the launcher is launched 
to compare local game files with the latest game build.  This file is also used by the 
Launcher_Validation scene to make sure everything matches as a final check before loading 
the login scene for the player.  A utility is included to generate this File Hash Validation List 
file for you. 

a. Open the “Validation Files Generator.exe” application from Launcher Build Kit -> Utilities 

 
b. Click the browse button 
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c. Browse to the location you built your game with in Unity (step 7) and click “select folder” 

 
d. The “Generate Hash Validation List” button is now enabled, click it 

 
e. The generator will inform you when it is finished and provide you with the output 

location, which should be two directories up from your build.  It should also 
automatically open the directory for you, revealing a file named 
“FileHashesList.launchervallst” – do NOT rename this file.  There is also a file called 
“ValidationString.txt”, which can be used to launch the current build of the game without 
the launcher if you have a reason to do need to do that (this is usually a file that will just 
be ignored)

 
Note: The hash list generator will add the .gltmp extension to files within the game build.  This prevents 
some web hosts from filtering out downloads they deem “unsafe” and allows the launcher to work more 
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reliably across web hosts. 
 

 
f. Copy the “FileHashesList.launchervallst” into the “Game File Hashes List” directory you 

created on your server underneath the Launcher Download Root URL you wrote down in 
Section 1, step b.  If you do not have this directory, just create it now as shown below, 
and then copy the “FileHashesList.launchervallst” file into it. 

 
 
------------------------------------- Other Information ------------------------------------- 

1. Updating the Launcher:  
This is covered in the “Customize your Launcher to match your game” section already, 
please see there. 

2. Updating the Game: 
Game updates are done by doing the following: 
* Repeat the “Create a Build of your Game in Unity” section 
* Repeat the “Create a File Hash Validation List and copy it up to your web server” section 
Doing these two steps will cause the launcher to see the new hash validation list each time 
the launcher starts, at which point it will know which file hashes changed and download only 
the needed files from the web server.  There is no need to update the launcher build by 
doing any of the other sections for a game build update, unless you want to change the 
launcher theme. 

3. Running the Launcher and finding the game: 
The launcher installer creates a desktop shortcut as well as a start menu shortcut.  There is 
also an add/remove programs entry created after running the launcher for the first time 
and selecting the game installation location (the uninstall string for this for the uninstall 
button in add/remove programs to work is currently not yet implemented, that is coming 
soon) 
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4. Distributing your game to your players 

Once implemented, all you need to do is provide a download of your Launcher-Install.exe to 
your users, it should be a very small download, as the launcher will pull down your game 
and install it once they install it. 

5. Where to find Launcher Logs 
The launcher comes with logging built in.  Logs can be found under the user’s 
AppData\Local\<company name>\<gamename> directory.  These can be very helpful for 
troubleshooting and assisting players with game installation issues. 

6. Support for other languages 
The launcher has been updated to utilize a LanguageOverrides.glconfig file if present in the 
Config directory next to the BaseConfig.congig.  The presence of this file allows you to 
override default text with text of your choosing.  Lines containing !VARIABLE! strings can 
utilize the strings to reinject variable values prior to being displayed to the user as well. 

7. Compatibility with web hosts 
The hash list generator will add the .gltmp extension to files within the game build.  This 
prevents some web hosts from filtering out downloads they deem “unsafe” and allows the 
launcher to work more reliably across web hosts.  
In addition, ensure your FTP client is set to upload files in binary mode vs. ASCII mode, as 
well as only allowing 1 simultaneous file transfer.  Not having these settings in place will 
cause the file (and thus the file hash) to change during upload, resulting in a constant 
update loop instead of successful patching. 

8.  
9.  
10.  


